admin

手动破解Daniu大牛-虚拟定位会员功能
手动破解新版本Daniu大牛-虚拟定位会员功能,并解决安卓版本8.0时老版本提示核心启动失败的问题。
扫描右侧二维码阅读全文
10
2018/05

手动破解Daniu大牛-虚拟定位会员功能

手动破解新版本Daniu大牛-虚拟定位会员功能,并解决安卓版本8.0时老版本提示核心启动失败的问题。


f_99118540.png
最近我的手机升级了系统,系统版本从7.1升级到了8.0,本来是不准备升级的,因为知道升级后也会出现各种问题,最明显的就是某些软件不支持更高的系统版本。
比如一直使用的虚拟定位软件"天下任我行"就打不开了,听说官方也跑路了,所以只能转战其他软件。
换了好几个定位软件也有XP框架,后来看中了"Daniu大牛-虚拟定位"这款软件。

使用过程中发现新版本的在使用软件内的功能时需要登录,部分功能还需要收费,在某网站看到老版本(1.1.8)可以绕过收费系统。

不过现在出现了两个问题

  • 老版本不支持安卓8.0系统,会提示核心启动失败
  • 新版本必须登录并且部分功能需要收费

先说第二个问题
在使用里面的功能的时候提示需要登录才能使用,说明在点击这个功能的时候软件加了一个判断,判断当前是否为登录状态,判断登录后是否为会员。
而老版本却没有这句判断,这就是为什么软件升级了,升级就是加了这局判断,我试着用老版本覆盖新版本,因为新版本已经支持8.0系统,安装后已经把核心文件写入手机存储,用老版本覆盖应该是行得通的(老版本提示核心文件启动失败,说明数据写入失败),覆盖的时候提示无法降级安装,
那么只需要把老版本变成比新版本高一级就行了,使用任意一款编程软件修改版本号
打开APP内AndroidManifest.xml文件,修改

android:versionCode="10"
android:versionName="1.1.8"

10和1.1.8为99和9.9.9
这样版本就变成了9.9.9
再试着覆盖安装,安装成功

上面也说了,老版本在使用功能的时候没有那句判断,所以可以直接点击使用

到这里应该已经明白怎么个意思了
将两个软件合并成一个软件

老版本不能写入核心文件,但新版本可以
新版本使用功能的时候会判断登录状态,但老版本没有

用新版本的核心用老版本的功能

第一个问题也同时被解决了

现在可以完美使用这款软件了,并且也不会出现强制更新弹出,因为老版本的版本号被修改了

该文章只提供相关思路,不提供软件,有能力的用户请支持正版软件,作者开发不易。奇趣博客发布,转载请注明出处。

Last modification:October 7th, 2018 at 04:32 pm
If you think my article is useful to you, please feel free to appreciate

Leave a Comment